CVE-2024-22365 Affecting linux-pam package, versions <1.6.0-r0


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.46% (37th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ALPINE320-LINUXPAM-7009970
  • published23 May 2024
  • disclosed6 Feb 2024

Introduced: 6 Feb 2024

CVE-2024-22365  (opens in a new tab)

How to fix?

Upgrade Alpine:3.20 linux-pam to version 1.6.0-r0 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream linux-pam package and not the linux-pam package as distributed by Alpine. See How to fix? for Alpine:3.20 relevant fixed versions and status.

linux-pam (aka Linux PAM) before 1.6.0 allows attackers to cause a denial of service (blocked login process) via mkfifo because the openat call (for protect_dir) lacks O_DIRECTORY.

CVSS Base Scores

version 3.1