Use After Free Affecting libkcapi package, versions <1.5.1-r0


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.14% (3rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ALPINE321-LIBKCAPI-19256951
  • published25 Aug 2026
  • disclosed5 Aug 2026

Introduced: 5 Aug 2026

CVE-2026-71226  (opens in a new tab)
CWE-416  (opens in a new tab)

How to fix?

Upgrade Alpine:3.21 libkcapi to version 1.5.1-r0 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libkcapi package and not the libkcapi package as distributed by Alpine. See How to fix? for Alpine:3.21 relevant fixed versions and status.

Memory Corruption via Uncanceled AIO Requests on Error: libkcapi's one-shot AIO path can return an error before all submitted IOCBs are drained, allowing later kernel writes into caller-owned output buffers.

CVSS Base Scores

version 3.1