Missing Encryption of Sensitive Data Affecting quassel package, versions <0.13.1-r6


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.62% (45th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ALPINE321-QUASSEL-8489161
  • published6 Dec 2024
  • disclosed17 Jun 2021

Introduced: 17 Jun 2021

CVE-2021-34825  (opens in a new tab)
CWE-311  (opens in a new tab)

How to fix?

Upgrade Alpine:3.21 quassel to version 0.13.1-r6 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream quassel package and not the quassel package as distributed by Alpine. See How to fix? for Alpine:3.21 relevant fixed versions and status.

Quassel through 0.13.1, when --require-ssl is enabled, launches without SSL or TLS support if a usable X.509 certificate is not found on the local system.

CVSS Base Scores

version 3.1