Improper Privilege Management Affecting bubblewrap package, versions <0.4.1-r0


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.9% (58th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ALPINE323-BUBBLEWRAP-14176668
  • published4 Dec 2025
  • disclosed31 Mar 2020

Introduced: 31 Mar 2020

CVE-2020-5291  (opens in a new tab)
CWE-269  (opens in a new tab)
CWE-648  (opens in a new tab)

How to fix?

Upgrade Alpine:3.23 bubblewrap to version 0.4.1-r0 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream bubblewrap package and not the bubblewrap package as distributed by Alpine. See How to fix? for Alpine:3.23 relevant fixed versions and status.

Bubblewrap (bwrap) before version 0.4.1, if installed in setuid mode and the kernel supports unprivileged user namespaces, then the bwrap --userns2 option can be used to make the setuid process keep running as root while being traceable. This can in turn be used to gain root permissions. Note that this only affects the combination of bubblewrap in setuid mode (which is typically used when unprivileged user namespaces are not supported) and the support of unprivileged user namespaces. Known to be affected are: * Debian testing/unstable, if unprivileged user namespaces enabled (not default) * Debian buster-backports, if unprivileged user namespaces enabled (not default) * Arch if using linux-hardened, if unprivileged user namespaces enabled (not default) * Centos 7 flatpak COPR, if unprivileged user namespaces enabled (not default) This has been fixed in the 0.4.1 release, and all affected users should update.

CVSS Base Scores

version 3.1