Improper Encoding or Escaping of Output Affecting croc package, versions <10.0.11-r0


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.37% (31st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ALPINE323-CROC-14177684
  • published4 Dec 2025
  • disclosed20 Sept 2023

Introduced: 20 Sep 2023

CVE-2023-43620  (opens in a new tab)
CWE-116  (opens in a new tab)

How to fix?

Upgrade Alpine:3.23 croc to version 10.0.11-r0 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream croc package and not the croc package as distributed by Alpine. See How to fix? for Alpine:3.23 relevant fixed versions and status.

An issue was discovered in Croc through 9.6.5. A sender may place ANSI or CSI escape sequences in a filename to attack the terminal device of a receiver.

CVSS Base Scores

version 3.1