CVE-2024-35164 Affecting guacamole-server package, versions <1.6.0-r0


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.52% (42nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ALPINE323-GUACAMOLESERVER-14180849
  • published4 Dec 2025
  • disclosed2 Jul 2025

Introduced: 2 Jul 2025

CVE-2024-35164  (opens in a new tab)

How to fix?

Upgrade Alpine:3.23 guacamole-server to version 1.6.0-r0 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream guacamole-server package and not the guacamole-server package as distributed by Alpine. See How to fix? for Alpine:3.23 relevant fixed versions and status.

The terminal emulator of Apache Guacamole 1.5.5 and older does not properly validate console codes received from servers via text-based protocols like SSH. If a malicious user has access to a text-based connection, a specially-crafted sequence of console codes could allow arbitrary code to be executed with the privileges of the running guacd process.

Users are recommended to upgrade to version 1.6.0, which fixes this issue.

CVSS Base Scores

version 3.1