Race Condition Affecting gvfs package, versions <1.40.2-r0


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
1.76% (77th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ALPINE324-GVFS-17300509
  • published11 Jun 2026
  • disclosed29 May 2019

Introduced: 29 May 2019

CVE-2019-12448  (opens in a new tab)
CWE-362  (opens in a new tab)

How to fix?

Upgrade Alpine:3.24 gvfs to version 1.40.2-r0 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream gvfs package and not the gvfs package as distributed by Alpine. See How to fix? for Alpine:3.24 relevant fixed versions and status.

An issue was discovered in GNOME gvfs 1.29.4 through 1.41.2. daemon/gvfsbackendadmin.c has race conditions because the admin backend doesn't implement query_info_on_read/write.