Use of Externally-Controlled Format String Affecting irssi package, versions <1.0.6-r0


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
1.91% (79th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ALPINE324-IRSSI-17300725
  • published11 Jun 2026
  • disclosed6 Jan 2018

Introduced: 6 Jan 2018

CVE-2018-5207  (opens in a new tab)
CWE-134  (opens in a new tab)

How to fix?

Upgrade Alpine:3.24 irssi to version 1.0.6-r0 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream irssi package and not the irssi package as distributed by Alpine. See How to fix? for Alpine:3.24 relevant fixed versions and status.

When using an incomplete variable argument, Irssi before 1.0.6 may access data beyond the end of the string.