Buffer Overflow Affecting liblouis package, versions <3.22.0-r0


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
1.45% (73rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ALPINE324-LIBLOUIS-17301001
  • published11 Jun 2026
  • disclosed13 Mar 2022

Introduced: 13 Mar 2022

CVE-2022-26981  (opens in a new tab)
CWE-120  (opens in a new tab)

How to fix?

Upgrade Alpine:3.24 liblouis to version 3.22.0-r0 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream liblouis package and not the liblouis package as distributed by Alpine. See How to fix? for Alpine:3.24 relevant fixed versions and status.

Liblouis through 3.21.0 has a buffer overflow in compilePassOpcode in compileTranslationTable.c (called, indirectly, by tools/lou_checktable.c).

CVSS Base Scores

version 3.1