Incorrect Calculation of Buffer Size Affecting libraw package, versions <0.22.1-r0


Severity

Recommended
0.0
critical
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.63% (48th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ALPINE324-LIBRAW-17300949
  • published11 Jun 2026
  • disclosed7 Apr 2026

Introduced: 7 Apr 2026

CVE-2026-20911  (opens in a new tab)
CWE-131  (opens in a new tab)

How to fix?

Upgrade Alpine:3.24 libraw to version 0.22.1-r0 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libraw package and not the libraw package as distributed by Alpine. See How to fix? for Alpine:3.24 relevant fixed versions and status.

A heap-based buffer overflow vulnerability exists in the HuffTable::initval functionality of LibRaw Commit 0b56545 and Commit d20315b. A specially crafted malicious file can lead to a heap buffer overflow. An attacker can provide a malicious file to trigger this vulnerability.

CVSS Base Scores

version 3.1