Memory Leak Affecting opensc package, versions <0.20.0-r0


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
2.2% (82nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ALPINE324-OPENSC-17302299
  • published11 Jun 2026
  • disclosed22 Jan 2019

Introduced: 22 Jan 2019

CVE-2019-6502  (opens in a new tab)
CWE-401  (opens in a new tab)

How to fix?

Upgrade Alpine:3.24 opensc to version 0.20.0-r0 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream opensc package and not the opensc package as distributed by Alpine. See How to fix? for Alpine:3.24 relevant fixed versions and status.

sc_context_create in ctx.c in libopensc in OpenSC 0.19.0 has a memory leak, as demonstrated by a call from eidenv.