Out-of-bounds Write Affecting pango package, versions <1.44.1-r0


Severity

Recommended
0.0
critical
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
6.27% (93rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ALPINE324-PANGO-17297685
  • published11 Jun 2026
  • disclosed19 Jul 2019

Introduced: 19 Jul 2019

CVE-2019-1010238  (opens in a new tab)
CWE-787  (opens in a new tab)

How to fix?

Upgrade Alpine:3.24 pango to version 1.44.1-r0 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream pango package and not the pango package as distributed by Alpine. See How to fix? for Alpine:3.24 relevant fixed versions and status.

Gnome Pango 1.42 and later is affected by: Buffer Overflow. The impact is: The heap based buffer overflow can be used to get code execution. The component is: function name: pango_log2vis_get_embedding_levels, assignment of nchars and the loop condition. The attack vector is: Bug can be used when application pass invalid utf-8 strings to functions like pango_itemize.

CVSS Base Scores

version 3.1