CVE-2026-9698 Affecting perl-dbi package, versions <1.648-r0


Severity

Recommended
0.0
critical
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.46% (40th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ALPINE324-PERLDBI-18310115
  • published26 Jul 2026
  • disclosed9 Jun 2026

Introduced: 9 Jun 2026

CVE-2026-9698  (opens in a new tab)

How to fix?

Upgrade Alpine:3.24 perl-dbi to version 1.648-r0 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream perl-dbi package and not the perl-dbi package as distributed by Alpine. See How to fix? for Alpine:3.24 relevant fixed versions and status.

DBI versions before 1.648 for Perl saved errors in a limited-sized buffer.

Error messages that were returned when RaiseError, PrintError or HandleError were set were written to a 200-byte buffer without a length limit.

Attackers that can influence the error text in an application can trigger a buffer overflow.

CVSS Base Scores

version 3.1