Memory Leak Affecting privoxy package, versions <3.0.33-r0


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
1.27% (70th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ALPINE324-PRIVOXY-17297948
  • published11 Jun 2026
  • disclosed23 Dec 2021

Introduced: 23 Dec 2021

CVE-2021-44542  (opens in a new tab)
CWE-401  (opens in a new tab)

How to fix?

Upgrade Alpine:3.24 privoxy to version 3.0.33-r0 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream privoxy package and not the privoxy package as distributed by Alpine. See How to fix? for Alpine:3.24 relevant fixed versions and status.

A memory leak vulnerability was found in Privoxy when handling errors.

CVSS Base Scores

version 3.1