Buffer Overflow Affecting proftpd package, versions <1.3.9e-r0


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.46% (40th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ALPINE324-PROFTPD-22151062
  • published3 Nov 2026
  • disclosed30 Oct 2026

Introduced: 30 Oct 2026

NewCVE-2026-119146  (opens in a new tab)
CWE-120  (opens in a new tab)

How to fix?

Upgrade Alpine:3.24 proftpd to version 1.3.9e-r0 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream proftpd package and not the proftpd package as distributed by Alpine. See How to fix? for Alpine:3.24 relevant fixed versions and status.

ProFTPD before 1.3.9e and 1.3.10rc5 contains a buffer overflow vulnerability in the mod_rewrite int:utf8trans RewriteMap that allows remote attackers to overwrite static buffers. Attackers can send FTP command arguments longer than 1024 bytes, without authentication if pre-login commands are rewritten, to corrupt session memory and crash the session.

CVSS Base Scores

version 3.1