CVE-2022-33070 Affecting protobuf-c package, versions <1.4.1-r0


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
1.11% (66th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ALPINE324-PROTOBUFC-17298042
  • published11 Jun 2026
  • disclosed23 Jun 2022

Introduced: 23 Jun 2022

CVE-2022-33070  (opens in a new tab)

How to fix?

Upgrade Alpine:3.24 protobuf-c to version 1.4.1-r0 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream protobuf-c package and not the protobuf-c package as distributed by Alpine. See How to fix? for Alpine:3.24 relevant fixed versions and status.

Protobuf-c v1.4.0 was discovered to contain an invalid arithmetic shift via the function parse_tag_and_wiretype in protobuf-c/protobuf-c.c. This vulnerability allows attackers to cause a Denial of Service (DoS) via unspecified vectors.

CVSS Base Scores

version 3.1