CVE-2023-32700 Affecting texlive package, versions <20230506.66984-r0


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.81% (57th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ALPINE324-TEXLIVE-17304009
  • published11 Jun 2026
  • disclosed20 May 2023

Introduced: 20 May 2023

CVE-2023-32700  (opens in a new tab)

How to fix?

Upgrade Alpine:3.24 texlive to version 20230506.66984-r0 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream texlive package and not the texlive package as distributed by Alpine. See How to fix? for Alpine:3.24 relevant fixed versions and status.

LuaTeX before 1.17.0 allows execution of arbitrary shell commands when compiling a TeX file obtained from an untrusted source. This occurs because luatex-core.lua lets the original io.popen be accessed. This also affects TeX Live before 2023 r66984 and MiKTeX before 23.5.

CVSS Base Scores

version 3.1