SQL Injection Affecting cacti package, versions <0.8.8g-r0


Severity

Recommended
0.0
high
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
2.32% (82nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ALPINE33-CACTI-468794
  • published22 Sept 2019
  • disclosed22 Sept 2019
  • creditUnknown

Introduced: 22 Sep 2019

CVE-2015-8369  (opens in a new tab)
CWE-89  (opens in a new tab)

How to fix?

Upgrade Alpine:3.3 cacti to version 0.8.8g-r0 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream cacti package and not the cacti package as distributed by Alpine. See How to fix? for Alpine:3.3 relevant fixed versions and status.

SQL injection vulnerability in include/top_graph_header.php in Cacti 0.8.8f and earlier allows remote attackers to execute arbitrary SQL commands via the rra_id parameter in a properties action to graph.php.

CVSS Base Scores

version 3.1