Environment Affecting jasper package, versions <1.900.1-r12


Severity

Recommended
0.0
high
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
3.27% (88th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ALPINE33-JASPER-468669
  • published22 Sept 2019
  • disclosed22 Sept 2019
  • creditUnknown

Introduced: 22 Sep 2019

CVE-2016-1577  (opens in a new tab)

How to fix?

Upgrade Alpine:3.3 jasper to version 1.900.1-r12 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream jasper package and not the jasper package as distributed by Alpine. See How to fix? for Alpine:3.3 relevant fixed versions and status.

Double free vulnerability in the jas_iccattrval_destroy function in JasPer 1.900.1 and earlier allows remote attackers to cause a denial of service (crash) or possibly execute arbitrary code via a crafted ICC color profile in a JPEG 2000 image file, a different vulnerability than CVE-2014-8137.