Information Exposure Affecting libgcrypt package, versions <1.6.5-r0


Severity

Recommended
0.0
low
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
0.43% (37th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ALPINE33-LIBGCRYPT-468748
  • published22 Sept 2019
  • disclosed22 Sept 2019
  • creditUnknown

Introduced: 22 Sep 2019

CVE-2015-7511  (opens in a new tab)
CWE-200  (opens in a new tab)

How to fix?

Upgrade Alpine:3.3 libgcrypt to version 1.6.5-r0 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libgcrypt package and not the libgcrypt package as distributed by Alpine. See How to fix? for Alpine:3.3 relevant fixed versions and status.

Libgcrypt before 1.6.5 does not properly perform elliptic-point curve multiplication during decryption, which makes it easier for physically proximate attackers to extract ECDH keys by measuring electromagnetic emanations.

CVSS Base Scores

version 3.1