Improper Input Validation Affecting libxrender package, versions <0.9.9-r2


Severity

Recommended
0.0
critical
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
3.72% (90th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ALPINE33-LIBXRENDER-468181
  • published22 Sept 2019
  • disclosed22 Sept 2019
  • creditUnknown

Introduced: 22 Sep 2019

CVE-2016-7949  (opens in a new tab)
CWE-20  (opens in a new tab)
CWE-787  (opens in a new tab)

How to fix?

Upgrade Alpine:3.3 libxrender to version 0.9.9-r2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libxrender package and not the libxrender package as distributed by Alpine. See How to fix? for Alpine:3.3 relevant fixed versions and status.

Multiple buffer overflows in the (1) XvQueryAdaptors and (2) XvQueryEncodings functions in X.org libXrender before 0.9.10 allow remote X servers to trigger out-of-bounds write operations via vectors involving length fields.