Out-of-bounds Read Affecting libxtst package, versions <1.2.2-r1


Severity

Recommended
0.0
critical
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
2.44% (83rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ALPINE33-LIBXTST-310016
  • published13 Dec 2016
  • disclosed13 Dec 2016

Introduced: 13 Dec 2016

CVE-2016-7951  (opens in a new tab)
CWE-125  (opens in a new tab)
CWE-190  (opens in a new tab)

How to fix?

Upgrade Alpine:3.3 libxtst to version 1.2.2-r1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libxtst package and not the libxtst package as distributed by Alpine. See How to fix? for Alpine:3.3 relevant fixed versions and status.

Multiple integer overflows in X.org libXtst before 1.2.3 allow remote X servers to trigger out-of-bounds memory access operations by leveraging the lack of range checks.

CVSS Base Scores

version 3.1