Cryptographic Issues Affecting nettle package, versions <3.2-r0


Severity

Recommended
0.0
critical
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
3.95% (90th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ALPINE33-NETTLE-468735
  • published22 Sept 2019
  • disclosed22 Sept 2019
  • creditUnknown

Introduced: 22 Sep 2019

CVE-2015-8804  (opens in a new tab)
CWE-310  (opens in a new tab)
CWE-254  (opens in a new tab)

How to fix?

Upgrade Alpine:3.3 nettle to version 3.2-r0 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream nettle package and not the nettle package as distributed by Alpine. See How to fix? for Alpine:3.3 relevant fixed versions and status.

x86_64/ecc-384-modp.asm in Nettle before 3.2 does not properly handle carry propagation and produces incorrect output in its implementation of the P-384 NIST elliptic curve, which allows attackers to have unspecified impact via unknown vectors.

CVSS Base Scores

version 3.1