Out-of-Bounds Affecting openvswitch package, versions <2.4.0-r2


Severity

Recommended
0.0
critical
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
6.4% (94th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ALPINE33-OPENVSWITCH-468632
  • published22 Sept 2019
  • disclosed22 Sept 2019
  • creditUnknown

Introduced: 22 Sep 2019

CVE-2016-2074  (opens in a new tab)
CWE-119  (opens in a new tab)

How to fix?

Upgrade Alpine:3.3 openvswitch to version 2.4.0-r2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream openvswitch package and not the openvswitch package as distributed by Alpine. See How to fix? for Alpine:3.3 relevant fixed versions and status.

Buffer overflow in lib/flow.c in ovs-vswitchd in Open vSwitch 2.2.x and 2.3.x before 2.3.3 and 2.4.x before 2.4.1 allows remote attackers to execute arbitrary code via crafted MPLS packets, as demonstrated by a long string in an ovs-appctl command.

CVSS Base Scores

version 3.1