Improper Input Validation Affecting perl-PathTools package, versions <3.62-r0


Severity

Recommended
0.0
high
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
3.12% (88th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ALPINE33-PERLPATHTOOLS-468634
  • published22 Sept 2019
  • disclosed22 Sept 2019
  • creditUnknown

Introduced: 22 Sep 2019

CVE-2015-8607  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

Upgrade Alpine:3.3 perl-PathTools to version 3.62-r0 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream perl-PathTools package and not the perl-PathTools package as distributed by Alpine. See How to fix? for Alpine:3.3 relevant fixed versions and status.

The canonpath function in the File::Spec module in PathTools before 3.62, as used in Perl, does not properly preserve the taint attribute of data, which might allow context-dependent attackers to bypass the taint protection mechanism via a crafted string.

CVSS Base Scores

version 3.1