Improper Input Validation Affecting phpmyadmin package, versions <4.5.5.1-r0


Severity

Recommended
0.0
medium
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
0.78% (55th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ALPINE33-PHPMYADMIN-468495
  • published22 Sept 2019
  • disclosed22 Sept 2019
  • creditUnknown

Introduced: 22 Sep 2019

CVE-2016-2562  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

Upgrade Alpine:3.3 phpmyadmin to version 4.5.5.1-r0 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream phpmyadmin package and not the phpmyadmin package as distributed by Alpine. See How to fix? for Alpine:3.3 relevant fixed versions and status.

The checkHTTP function in libraries/Config.class.php in phpMyAdmin 4.5.x before 4.5.5.1 does not verify X.509 certificates from api.github.com SSL servers, which allows man-in-the-middle attackers to spoof these servers and obtain sensitive information via a crafted certificate.