Out-of-Bounds Affecting poppler package, versions <0.38.0-r1


Severity

Recommended
0.0
high
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
4.56% (92nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ALPINE33-POPPLER-468529
  • published22 Sept 2019
  • disclosed22 Sept 2019
  • creditUnknown

Introduced: 22 Sep 2019

CVE-2015-8868  (opens in a new tab)
CWE-119  (opens in a new tab)

How to fix?

Upgrade Alpine:3.3 poppler to version 0.38.0-r1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream poppler package and not the poppler package as distributed by Alpine. See How to fix? for Alpine:3.3 relevant fixed versions and status.

Heap-based buffer overflow in the ExponentialFunction::ExponentialFunction function in Poppler before 0.40.0 allows remote attackers to cause a denial of service (memory corruption and crash) or possibly execute arbitrary code via an invalid blend mode in the ExtGState dictionary in a crafted PDF document.

CVSS Base Scores

version 3.1