OS Command Injection Affecting py-pygments package, versions <2.0.2-r2


Severity

Recommended
0.0
critical
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
6.72% (94th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ALPINE33-PYPYGMENTS-468386
  • published22 Sept 2019
  • disclosed22 Sept 2019
  • creditUnknown

Introduced: 22 Sep 2019

CVE-2015-8557  (opens in a new tab)
CWE-78  (opens in a new tab)

How to fix?

Upgrade Alpine:3.3 py-pygments to version 2.0.2-r2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream py-pygments package and not the py-pygments package as distributed by Alpine. See How to fix? for Alpine:3.3 relevant fixed versions and status.

The FontManager._get_nix_font_path function in formatters/img.py in Pygments 1.2.2 through 2.0.2 allows remote attackers to execute arbitrary commands via shell metacharacters in a font name.

CVSS Base Scores

version 3.1