Out-of-Bounds Affecting vlc package, versions <2.2.4-r0


Severity

Recommended
0.0
critical
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
24.75% (98th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ALPINE33-VLC-468451
  • published22 Sept 2019
  • disclosed22 Sept 2019
  • creditUnknown

Introduced: 22 Sep 2019

CVE-2016-5108  (opens in a new tab)
CWE-119  (opens in a new tab)

How to fix?

Upgrade Alpine:3.3 vlc to version 2.2.4-r0 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream vlc package and not the vlc package as distributed by Alpine. See How to fix? for Alpine:3.3 relevant fixed versions and status.

Buffer overflow in the DecodeAdpcmImaQT function in modules/codec/adpcm.c in VideoLAN VLC media player before 2.2.4 allows remote attackers to cause a denial of service (crash) or possibly execute arbitrary code via a crafted QuickTime IMA file.