Use After Free Affecting gst-plugins-bad1 package, versions <1.8.3-r0


Severity

Recommended
0.0
high
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
3.8% (90th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ALPINE34-GSTPLUGINSBAD1-468028
  • published22 Sept 2019
  • disclosed22 Sept 2019
  • creditUnknown

Introduced: 22 Sep 2019

CVE-2017-5843  (opens in a new tab)
CWE-416  (opens in a new tab)

How to fix?

Upgrade Alpine:3.4 gst-plugins-bad1 to version 1.8.3-r0 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream gst-plugins-bad1 package and not the gst-plugins-bad1 package as distributed by Alpine. See How to fix? for Alpine:3.4 relevant fixed versions and status.

Multiple use-after-free vulnerabilities in the (1) gst_mini_object_unref, (2) gst_tag_list_unref, and (3) gst_mxf_demux_update_essence_tracks functions in GStreamer before 1.10.3 allow remote attackers to cause a denial of service (crash) via vectors involving stream tags, as demonstrated by 02785736.mxf.