Use After Free Affecting pcsc-lite package, versions <1.8.20-r0


Severity

Recommended
0.0
high
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
4.04% (91st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ALPINE34-PCSCLITE-468135
  • published22 Sept 2019
  • disclosed22 Sept 2019
  • creditUnknown

Introduced: 22 Sep 2019

CVE-2016-10109  (opens in a new tab)
CWE-416  (opens in a new tab)

How to fix?

Upgrade Alpine:3.4 pcsc-lite to version 1.8.20-r0 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream pcsc-lite package and not the pcsc-lite package as distributed by Alpine. See How to fix? for Alpine:3.4 relevant fixed versions and status.

Use-after-free vulnerability in pcsc-lite before 1.8.20 allows a remote attackers to cause denial of service (crash) via a command that uses "cardsList" after the handle has been released through the SCardReleaseContext function.