Out-of-Bounds Affecting quagga package, versions <1.0.20160315-r0


Severity

Recommended
0.0
high
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
13.33% (97th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ALPINE34-QUAGGA-468630
  • published22 Sept 2019
  • disclosed22 Sept 2019
  • creditUnknown

Introduced: 22 Sep 2019

CVE-2016-2342  (opens in a new tab)
CWE-119  (opens in a new tab)

How to fix?

Upgrade Alpine:3.4 quagga to version 1.0.20160315-r0 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream quagga package and not the quagga package as distributed by Alpine. See How to fix? for Alpine:3.4 relevant fixed versions and status.

The bgp_nlri_parse_vpnv4 function in bgp_mplsvpn.c in the VPNv4 NLRI parser in bgpd in Quagga before 1.0.20160309, when a certain VPNv4 configuration is used, relies on a Labeled-VPN SAFI routes-data length field during a data copy, which allows remote attackers to execute arbitrary code or cause a denial of service (stack-based buffer overflow) via a crafted packet.