NULL Pointer Dereference Affecting strongswan package, versions <5.4.0-r3


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
2.83% (87th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ALPINE34-STRONGSWAN-385088
  • published18 Aug 2017
  • disclosed18 Aug 2017

Introduced: 18 Aug 2017

CVE-2017-11185  (opens in a new tab)
CWE-476  (opens in a new tab)

How to fix?

Upgrade Alpine:3.4 strongswan to version 5.4.0-r3 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream strongswan package and not the strongswan package as distributed by Alpine. See How to fix? for Alpine:3.4 relevant fixed versions and status.

The gmp plugin in strongSwan before 5.6.0 allows remote attackers to cause a denial of service (NULL pointer dereference and daemon crash) via a crafted RSA signature.