Resource Exhaustion Affecting subversion package, versions <1.9.5-r0


Severity

Recommended
0.0
medium
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
6.38% (94th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ALPINE34-SUBVERSION-468132
  • published22 Sept 2019
  • disclosed22 Sept 2019
  • creditUnknown

Introduced: 22 Sep 2019

CVE-2016-8734  (opens in a new tab)
CWE-400  (opens in a new tab)

How to fix?

Upgrade Alpine:3.4 subversion to version 1.9.5-r0 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream subversion package and not the subversion package as distributed by Alpine. See How to fix? for Alpine:3.4 relevant fixed versions and status.

Apache Subversion's mod_dontdothat module and HTTP clients 1.4.0 through 1.8.16, and 1.9.0 through 1.9.4 are vulnerable to a denial-of-service attack caused by exponential XML entity expansion. The attack can cause the targeted process to consume an excessive amount of CPU resources or memory.