Improper Input Validation Affecting wpa_supplicant package, versions <2.5-r3


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
2.86% (85th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ALPINE34-WPASUPPLICANT-276474
  • published9 May 2016
  • disclosed9 May 2016

Introduced: 9 May 2016

CVE-2016-4476  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

Upgrade Alpine:3.4 wpa_supplicant to version 2.5-r3 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream wpa_supplicant package and not the wpa_supplicant package as distributed by Alpine. See How to fix? for Alpine:3.4 relevant fixed versions and status.

hostapd 0.6.7 through 2.5 and wpa_supplicant 0.6.7 through 2.5 do not reject \n and \r characters in passphrase parameters, which allows remote attackers to cause a denial of service (daemon outage) via a crafted WPS operation.

CVSS Base Scores

version 3.1