Out-of-bounds Read Affecting libplist package, versions <2.0.0-r0


Severity

Recommended
0.0
critical
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
2.85% (87th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ALPINE35-LIBPLIST-468102
  • published22 Sept 2019
  • disclosed22 Sept 2019
  • creditUnknown

Introduced: 22 Sep 2019

CVE-2017-5209  (opens in a new tab)
CWE-125  (opens in a new tab)

How to fix?

Upgrade Alpine:3.5 libplist to version 2.0.0-r0 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libplist package and not the libplist package as distributed by Alpine. See How to fix? for Alpine:3.5 relevant fixed versions and status.

The base64decode function in base64.c in libimobiledevice libplist through 1.12 allows attackers to obtain sensitive information from process memory or cause a denial of service (buffer over-read) via split encoded Apple Property List data.