Integer Overflow or Wraparound Affecting python2 package, versions <2.7.14-r0


Severity

Recommended
0.0
critical
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
7.94% (95th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ALPINE36-PYTHON2-278240
  • published17 Nov 2017
  • disclosed17 Nov 2017

Introduced: 17 Nov 2017

CVE-2017-1000158  (opens in a new tab)
CWE-190  (opens in a new tab)

How to fix?

Upgrade Alpine:3.6 python2 to version 2.7.14-r0 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream python2 package and not the python2 package as distributed by Alpine. See How to fix? for Alpine:3.6 relevant fixed versions and status.

CPython (aka Python) up to 2.7.13 is vulnerable to an integer overflow in the PyString_DecodeEscape function in stringobject.c, resulting in heap-based buffer overflow (and possible arbitrary code execution)

CVSS Base Scores

version 3.1