Information Exposure Through Log Files Affecting aria2 package, versions <1.33.1-r1


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.35% (27th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ALPINE37-ARIA2-343739
  • published2 Jan 2019
  • disclosed2 Jan 2019

Introduced: 2 Jan 2019

CVE-2019-3500  (opens in a new tab)
CWE-532  (opens in a new tab)

How to fix?

Upgrade Alpine:3.7 aria2 to version 1.33.1-r1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream aria2 package and not the aria2 package as distributed by Alpine. See How to fix? for Alpine:3.7 relevant fixed versions and status.

aria2c in aria2 1.33.1, when --log is used, can store an HTTP Basic Authentication username and password in a file, which might allow local users to obtain sensitive information by reading this file.

CVSS Base Scores

version 3.1