Integer Overflow or Wraparound Affecting gsoap package, versions <2.8.50-r0


Severity

Recommended
0.0
high
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
42.08% (99th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ALPINE37-GSOAP-467912
  • published22 Sept 2019
  • disclosed22 Sept 2019
  • creditUnknown

Introduced: 22 Sep 2019

CVE-2017-9765  (opens in a new tab)
CWE-190  (opens in a new tab)

How to fix?

Upgrade Alpine:3.7 gsoap to version 2.8.50-r0 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream gsoap package and not the gsoap package as distributed by Alpine. See How to fix? for Alpine:3.7 relevant fixed versions and status.

Integer overflow in the soap_get function in Genivia gSOAP 2.7.x and 2.8.x before 2.8.48, as used on Axis cameras and other devices, allows remote attackers to execute arbitrary code or cause a denial of service (stack-based buffer overflow and application crash) via a large XML document, aka Devil's Ivy. NOTE: the large document would be blocked by many common web-server configurations on general-purpose computers.