Out-of-Bounds Affecting pango package, versions <1.40.14-r1


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

Exploit Maturity
Proof of Concept
EPSS
11.36% (96th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ALPINE37-PANGO-273411
  • published22 Aug 2018
  • disclosed24 Aug 2018

Introduced: 22 Aug 2018

CVE-2018-15120  (opens in a new tab)
CWE-119  (opens in a new tab)

How to fix?

Upgrade Alpine:3.7 pango to version 1.40.14-r1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream pango package and not the pango package as distributed by Alpine. See How to fix? for Alpine:3.7 relevant fixed versions and status.

libpango in Pango 1.40.8 through 1.42.3, as used in hexchat and other products, allows remote attackers to cause a denial of service (application crash) or possibly have unspecified other impact via crafted text with invalid Unicode sequences.

CVSS Base Scores

version 3.1