Improper Input Validation Affecting python3 package, versions <3.6.5-r0


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
4.74% (92nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ALPINE37-PYTHON3-261286
  • published19 Jun 2018
  • disclosed19 Jun 2018

Introduced: 19 Jun 2018

CVE-2018-1061  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

Upgrade Alpine:3.7 python3 to version 3.6.5-r0 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream python3 package and not the python3 package as distributed by Alpine. See How to fix? for Alpine:3.7 relevant fixed versions and status.

python before versions 2.7.15, 3.4.9, 3.5.6rc1, 3.6.5rc1 and 3.7.0 is vulnerable to catastrophic backtracking in the difflib.IS_LINE_JUNK method. An attacker could use this flaw to cause denial of service.

References