Out-of-bounds Write Affecting quassel package, versions <0.12.5.-r0


Severity

Recommended
0.0
critical
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
4.05% (91st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ALPINE37-QUASSEL-383395
  • published8 May 2018
  • disclosed8 May 2018

Introduced: 8 May 2018

CVE-2018-1000178  (opens in a new tab)
CWE-787  (opens in a new tab)

How to fix?

Upgrade Alpine:3.7 quassel to version 0.12.5.-r0 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream quassel package and not the quassel package as distributed by Alpine. See How to fix? for Alpine:3.7 relevant fixed versions and status.

A heap corruption of type CWE-120 exists in quassel version 0.12.4 in quasselcore in void DataStreamPeer::processMessage(const QByteArray &msg) datastreampeer.cpp line 62 that allows an attacker to execute code remotely.