Improper Authentication Affecting tinc package, versions <1.0.35-r0


Severity

Recommended
0.0
low
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
1.36% (68th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ALPINE38-TINC-344387
  • published9 Oct 2018
  • disclosed10 Oct 2018

Introduced: 9 Oct 2018

CVE-2018-16738  (opens in a new tab)
CWE-287  (opens in a new tab)

How to fix?

Upgrade Alpine:3.8 tinc to version 1.0.35-r0 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream tinc package and not the tinc package as distributed by Alpine. See How to fix? for Alpine:3.8 relevant fixed versions and status.

tinc 1.0.30 through 1.0.34 has a broken authentication protocol, although there is a partial mitigation. This is fixed in 1.1.

CVSS Base Scores

version 3.1