Improper Input Validation Affecting libvirt package, versions <5.5.0-r2


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.81% (53rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ALPINE39-LIBVIRT-598885
  • published19 Aug 2020
  • disclosed19 Mar 2020

Introduced: 19 Mar 2020

CVE-2019-20485  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

Upgrade Alpine:3.9 libvirt to version 5.5.0-r2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libvirt package and not the libvirt package as distributed by Alpine. See How to fix? for Alpine:3.9 relevant fixed versions and status.

qemu/qemu_driver.c in libvirt before 6.0.0 mishandles the holding of a monitor job during a query to a guest agent, which allows attackers to cause a denial of service (API blockage).

CVSS Base Scores

version 3.1