Missing Authorization Affecting postfixadmin package, versions <3.0.2-r0


Severity

Recommended
0.0
low
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
14.95% (97th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ALPINE39-POSTFIXADMIN-338398
  • published20 Mar 2017
  • disclosed20 Mar 2017

Introduced: 20 Mar 2017

CVE-2017-5930  (opens in a new tab)
CWE-862  (opens in a new tab)

How to fix?

Upgrade Alpine:3.9 postfixadmin to version 3.0.2-r0 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream postfixadmin package and not the postfixadmin package as distributed by Alpine. See How to fix? for Alpine:3.9 relevant fixed versions and status.

The AliasHandler component in PostfixAdmin before 3.0.2 allows remote authenticated domain admins to delete protected aliases via the delete parameter to delete.php, involving a missing permission check.

CVSS Base Scores

version 3.1