Arbitrary Code Injection Affecting awx package, versions <24.6.1-r46


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.27% (17th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-CHAINGUARDLATEST-AWX-21694240
  • published25 Oct 2026
  • disclosed3 Aug 2026

Introduced: 3 Aug 2026

CVE-2026-69097  (opens in a new tab)
CWE-74  (opens in a new tab)

How to fix?

Upgrade Chainguard awx to version 24.6.1-r46 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream awx package and not the awx package as distributed by Chainguard. See How to fix? for Chainguard relevant fixed versions and status.

GitPython before 3.1.53 fails to properly escape section names in git config files, allowing attackers to inject arbitrary configuration directives through malicious submodule names. Attackers can inject core.sshCommand or other dangerous config keys into the victim's .git/config via create_submodule or clone_from operations, achieving remote code execution when git performs ssh operations.

CVSS Base Scores

version 3.1