Out-of-bounds Read Affecting binutils package, versions <2.46.1-r2


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.19% (9th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-CHAINGUARDLATEST-BINUTILS-17705707
  • published30 Jun 2026
  • disclosed16 Mar 2026

Introduced: 16 Mar 2026

CVE-2026-3441  (opens in a new tab)
CWE-125  (opens in a new tab)

How to fix?

Upgrade Chainguard binutils to version 2.46.1-r2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream binutils package and not the binutils package as distributed by Chainguard. See How to fix? for Chainguard relevant fixed versions and status.

A flaw was found in GNU Binutils. This heap-based buffer overflow vulnerability, specifically an out-of-bounds read in the bfd linker, allows an attacker to gain access to sensitive information. By convincing a user to process a specially crafted XCOFF object file, an attacker can trigger this flaw, potentially leading to information disclosure or an application level denial of service.

CVSS Base Scores

version 3.1