Integer Overflow or Wraparound Affecting chaos-tproxy package, versions <0.5.4-r2


Severity

Recommended
0.0
critical
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
1.16% (66th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-CHAINGUARDLATEST-CHAOSTPROXY-16417516
  • published4 May 2026
  • disclosed7 Jul 2021

Introduced: 7 Jul 2021

CVE-2021-32714  (opens in a new tab)
CWE-190  (opens in a new tab)

How to fix?

Upgrade Chainguard chaos-tproxy to version 0.5.4-r2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream chaos-tproxy package and not the chaos-tproxy package as distributed by Chainguard. See How to fix? for Chainguard relevant fixed versions and status.

hyper is an HTTP library for Rust. In versions prior to 0.14.10, hyper's HTTP server and client code had a flaw that could trigger an integer overflow when decoding chunk sizes that are too big. This allows possible data loss, or if combined with an upstream HTTP proxy that allows chunk sizes larger than hyper does, can result in "request smuggling" or "desync attacks." The vulnerability is patched in version 0.14.10. Two possible workarounds exist. One may reject requests manually that contain a Transfer-Encoding header or ensure any upstream proxy rejects Transfer-Encoding chunk sizes greater than what fits in 64-bit unsigned integers.

CVSS Base Scores

version 3.1