Information Exposure Affecting data-prepper package, versions <2.16.0-r3


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.43% (37th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-CHAINGUARDLATEST-DATAPREPPER-21709134
  • published26 Oct 2026
  • disclosed14 Jul 2026

Introduced: 14 Jul 2026

CVE-2026-10051  (opens in a new tab)
CWE-200  (opens in a new tab)

How to fix?

Upgrade Chainguard data-prepper to version 2.16.0-r3 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream data-prepper package and not the data-prepper package as distributed by Chainguard. See How to fix? for Chainguard relevant fixed versions and status.

In Eclipse Jetty, a first HTTP/1.1 request with trailers causes the server to retain the trailers in subsequent requests performed over the same connection. Subsequent request that do not have trailers report the trailers of the first request. Subsequent request that do have trailers report the union of trailers of the first request and the current request.

CVSS Base Scores

version 3.1