Out-of-bounds Write Affecting debezium-connector-ibmi-3.5 package, versions <3.5.2-r9


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.3% (23rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-CHAINGUARDLATEST-DEBEZIUMCONNECTORIBMI35-21779809
  • published29 Oct 2026
  • disclosed18 Sept 2026

Introduced: 18 Sep 2026

CVE-2026-93451  (opens in a new tab)
CWE-787  (opens in a new tab)

How to fix?

Upgrade Chainguard debezium-connector-ibmi-3.5 to version 3.5.2-r9 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream debezium-connector-ibmi-3.5 package and not the debezium-connector-ibmi-3.5 package as distributed by Chainguard. See How to fix? for Chainguard relevant fixed versions and status.

snappy-java through 1.1.10.8 contains a buffer overflow vulnerability in typed Snappy.uncompress*Array methods that allocate output arrays by dividing uncompressed length by element size but pass the undivided length to native code. Attackers controlling compressed input can cause misaligned length values to write past array bounds with attacker-controlled bytes, corrupting heap memory.

CVSS Base Scores

version 3.1